Ticket #293 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Consider bumping the so version of misc libs

Reported by: ingvar Owned by: des
Priority: normal Milestone: Varnish 2.0 release
Component: build Version: trunk
Severity: normal Keywords: library so rpmbuild
Cc:

Description

I ran into all sorts of trouble last night when I tried to build varnish for Fedora9, and adding the test suite to the build. Finally, I found that LD_LIBRARY_PATH in the test script was ignored by rpmbuild, and since I had libvarnish-1.1.x, with matching so version, "make test" linked against libraries in /usr/lib, and varnishd in the test behaved ... very strange indeed.

If varnish-2.0-presomething from svn is incompatible with eg. libvarnish.so.0 from varnish-1.1.x, the so version number of the libraries should be considered bumped.

Ingvar

Change History

comment:1 Changed 6 years ago by tfheen

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in revision 3140.

Note: See TracTickets for help on using tickets.