Ticket #1258 (closed defect: fixed)

Opened 15 months ago

Last modified 14 months ago

Failure to build due to aclocal macros

Reported by: richo Owned by:
Priority: normal Milestone:
Component: build Version: trunk
Severity: normal Keywords:
Cc:

Description

When running autogen.sh on my OSX 10.8 system from master on the github mirror, I get:

+ aclocal -I m4 configure.ac:7: error: 'AM_CONFIG_HEADER': this macro is obsolete.

You should use the 'AC_CONFIG_HEADERS' macro instead.

/usr/local/Cellar/automake/1.13.1/share/aclocal-1.13/obsolete-err.m4:14: AM_CONFIG_HEADER is expanded from... configure.ac:7: the top level

I've attached a patch to use the new header (And one which fixes a ton of trailing whitespace I found while I was at it).

My branch is also visible with a signed tag at  https://github.com/richo/Varnish-Cache/tree/for_varnish/am_header

Attachments

0001-Fix-deprecation-error-from-aclocal.patch Download (736 bytes) - added by richo 15 months ago.
0002-Whitespace.patch Download (2.3 KB) - added by richo 15 months ago.

Change History

Changed 15 months ago by richo

Changed 15 months ago by richo

comment:1 Changed 14 months ago by Tollef Fog Heen <tfheen@…>

In [3be4a80b7893807953ce067159d3bfab059f3bd1]:

Change AM_CONFIG_HEADER to AC_CONFIG_HEADERS

Fixes #1258

comment:2 Changed 14 months ago by Tollef Fog Heen <tfheen@…>

  • Status changed from new to closed
  • Resolution set to fixed

(In [3be4a80b7893807953ce067159d3bfab059f3bd1]) Change AM_CONFIG_HEADER to AC_CONFIG_HEADERS

Fixes #1258

Note: See TracTickets for help on using tickets.