Ticket #1247 (closed defect: worksforme)

Opened 16 months ago

Last modified 5 months ago

yum installation error "[Errno -1] Header is not complete."

Reported by: Damien Owned by: tfheen
Priority: high Milestone:
Component: build Version: trunk
Severity: major Keywords:
Cc:

Description (last modified by tfheen) (diff)

Getting the following errors when trying to install varnish via repository provided by varnish-cache.org on a RHEL5 :

yum install varnish
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
epel                      100% |=========================| 3.7 kB    00:00     
accpkgs                   100% |=========================|  951 B    00:00     
varnish-3.0               100% |=========================|  951 B    00:00     
update                    100% |=========================|  951 B    00:00     
base                      100% |=========================| 1.1 kB    00:00     
addons                    100% |=========================| 1.9 kB    00:00     
extras                    100% |=========================| 2.1 kB    00:00     
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for varnish to pack into transaction set.
varnish-3.0.3-1.el5.cento 100% |=========================|  23 kB    00:00     
http://repo.varnish-cache.org/redhat/varnish-3.0/el5/x86_64/varnish-3.0.3-1.el5.centos.x86_64.rpm: [Errno -1] Header is not complete.
Trying other mirror.
Error: failure: varnish-3.0.3-1.el5.centos.x86_64.rpm from varnish-3.0: [Errno 256] No more mirrors to try.

Change History

comment:1 Changed 16 months ago by tfheen

  • Description modified (diff)

comment:2 Changed 16 months ago by tfheen

  • Owner set to tfheen

comment:3 Changed 16 months ago by Saud

Faced the same problem .. please fix it!

comment:4 Changed 15 months ago by tfheen

Does wget-ing the file and installing by hand locally work for you? Can you please provide information about your IPs?

comment:5 Changed 15 months ago by Saud

No I just try by (yum). Do you need my download the source and build it manually?

What do you mean by information about my IP? which information you need?

Last edited 15 months ago by Saud (previous) (diff)

comment:6 Changed 15 months ago by lkarsten

One of the things that needs to be ruled out is if this is a network issue.

Downloading it with another client, and trying to install it manually with rpm will tell us this.

Please also provide a traceroute towards repo.varnish-cache.org with a timestamp (run /bin/date) , so we can try to correlate your requests with our logs.

comment:7 Changed 15 months ago by Damien

Bonjour, Mon ip de sortie est 90.85 .8.1

I also, try : #rpm --nosignature -i varnish-3.0.3-1.el5.centos.x86_64.rpm error: Failed dependencies:

libvarnishapi.so.1()(64bit) is needed by varnish-3.0.3-1.el5.centos.x86_64 libvarnishapi.so.1(LIBVARNISHAPI_1.0)(64bit) is needed by varnish-3.0.3-1.el5.centos.x86_64 varnish-libs = 3.0.3-1.el5.centos is needed by varnish-3.0.3-1.el5.centos.x86_64

comment:8 Changed 5 months ago by tfheen

  • Status changed from new to closed
  • Resolution set to worksforme

I've not heard any other reports about this, and everything looks fine here, so closing.

If you download manually, you need to download the libvarnishapi package as well.

Note: See TracTickets for help on using tickets.